Reporting & Data Warehouse Delays

Incident Report for PatientIQ

Resolved

This incident has been resolved.
Posted Apr 30, 2026 - 23:32 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 30, 2026 - 23:14 CDT

Investigating

Reporting and data warehouse features are currently delayed. We are working with our upstream data provider to resolve the issue.
Posted Apr 30, 2026 - 21:53 CDT
This incident affected: PatientIQ Web Application (Reports).